Author Topic: openvpn теряет соединение и не подключается  (Read 1622 times)

0 Members and 1 Guest are viewing this topic.

Offline Kavka

  • Jr. Member
  • **
  • Posts: 75
  • Karma: +0/-0
Всем здрасте!

Как говориться, лыжи не едут уже.
Имеется. OpenVPN сервер под линуксом. Клиент на винде 8 с подключением через 3G-модем.
В винде openvpn включен как сервис, чтобы всё запускалось автоматически.
И оно запускается. Но тонель через какое-то время перестаёт пинговаться пока не перезапустишь сервис openvpn.
Интернет на клиентском компе при этом работает (3G-модем пашет).
keepalive на клиенте прописан. Сервер с фиксированным DNS-именем/IP-адресом. Что ещё то???
Есть у кого-нибудь идеи/соображения?

Сервер
Code: [Select]
mode p2p
proto udp
port 11198
dev tun5

ifconfig 192.168.100.21 192.168.100.22
secret blabla.key
cipher AES-128-CBC

user nobody
group nogroup

keepalive 10 30
ping-timer-rem
persist-tun
persist-key

fragment 1300
mssfix

sndbuf 393216
rcvbuf 393216

comp-lzo

verb 3

Клиент
Code: [Select]
remote blabla-adress 11197 udp

mode p2p
dev tun

ifconfig 192.168.100.22 192.168.100.21
secret blabla.key
cipher AES-128-CBC

user nobody
group nogroup

keepalive 10 30
persist-tun
persist-key
persist-remote-ip

fragment 1300
mssfix

resolv-retry infinite

sndbuf 393216
rcvbuf 393216

comp-lzo

verb 3
« Last Edit: October 26, 2015, 11:38:37 by Kavka »
Tomsk OpenSUSE Team

Offline SinClaus

  • Sr. Member
  • ****
  • Posts: 453
  • Karma: +6/-2
Поставь запуск от рута и мучься. Обычно падает при контрольном перезапуске в 00 часов, если путём не сконфигурено на запуски от nobody.
Самый страшный вирус называется юзер.