Author Topic: Вопрос по библиотеке qpsql4.dll  (Read 3977 times)

0 Members and 1 Guest are viewing this topic.

Offline koss

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Вопрос по библиотеке qpsql4.dll
« on: August 22, 2009, 17:50:10 »
Я не могу скомпилировать данную библиотеку средствами опенсорсной Qt4 и mingw , помоему ему не нравятся исходники постгреса которые я ему подсовываю (исходники перекачал с установленой на линуксе постгрес, *.а библиотеки вроде все как требует mingw) при сборке из дириктории src\plugin\sqldriver\pqsl вылазиют какие то undefined dependance.
У меня вопрос кто нибудь может скомпилировать qpsql4.dll у себя в виндовсе и прислать мне эту библиотеку? И будет ли такая схема работать?

Offline Jatz

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Вопрос по библиотеке qpsql4.dll
« Reply #1 on: March 04, 2010, 14:53:15 »
Quote from: koss
Я не могу скомпилировать данную библиотеку средствами опенсорсной Qt4 и mingw , помоему ему не нравятся исходники постгреса которые я ему подсовываю (исходники перекачал с установленой на линуксе постгрес, *.а библиотеки вроде все как требует mingw) при сборке из дириктории src\plugin\sqldriver\pqsl вылазиют какие то undefined dependance.
У меня вопрос кто нибудь может скомпилировать qpsql4.dll у себя в виндовсе и прислать мне эту библиотеку? И будет ли такая схема работать?
вопрос в том какие, пути к libpq прописал? + какая версия постгреса? если я тебе просто длльку пришлю работать не будет

P.S. кто-нибудь  январский Qt удачно пересобирал с драйвером постгреса в статике?